杰者的备忘录

当前位置:   网站首页 >> 杂烩

[分享源码]不支持IE低版本的提示页面

由于WINDOWS XP已经淘汰一段时间了,IE低版本的份额也在逐步减少,所以我计划接下来做的网页都不再支持IE9以下的低版本了这些。

所以应该对IE6、IE7、IE8这些访客都进行提示,让他们更换浏览器访问。找了一圈发现大多数大站的提示都做得比较简陋。其他博客分享出来的也都不是太完善,可能这事是太没有技术含量,所以都不太注重。

于是就自己花了一晚上折腾了一个出来。虽然没有技术含量,但是还是费了一番功夫的,装了个XP的虚拟机,把各路浏览器都装一遍只为拿到图标,然后抠背景什么的。


这是成果:

IE不兼容提示页面.zip

注意:压缩包里已经附带了图标的PSD了,如果你觉得背景色不好看,可以自己重新调整。


比其他地方分享现成的代码更完善的点在于:

1、列出的都是国人比较常用的浏览器,并且全部都链接到官网下载。

2、提示页面全部外链都加了nofollow标签,防止自己站的SEO权重被带走。

3、meta加了none的robots标签,防止这个提示页面被搜索引擎收录。

4、JS判断了如果访问此页面的不是IE低版本就会自动跳转回域名根目录。防止访客直接复制这个提示页面的URL去非IE低版本的浏览器访问,导致莫名其妙。


效果如下:


使用方法:

把压缩包里的页面跟图片传到网站目录里然后在网站上的其他页面的head里加入

<!--[if lt IE 9]><meta http-equiv="refresh" content="0;url=ie.html"/><![endif]-->

折腾不容易,转载请注明来自jiezhe.net

网友评论1

  1. 来宾2018-02-12 05:41:39 回复

    瞎折腾

发表我的评论

Hi,您需要填写昵称和邮箱!

  • 必填项